Increased Rate Limiting on Konnect APIs via Private Link

Incident Report for Kong

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 17:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 16:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2025 - 16:32 UTC

Investigating

Some clients using Konnect APIs over Private Link are experiencing unexpected rate limiting. This has been identified as an issue with our edge proxy failing to differentiate different clients for rate limits. The team is currently working to resolve and restore full rate limit capacity to all clients
Posted Jul 16, 2025 - 15:03 UTC
This incident affected: Kong Konnect Cloud.